error please select android sdk

点app运行时报如下错:

1
Error:please select android sdk

且app module上打了个红叉,无法点击运行

提示找不到SDK

打开app.iml文件修改如下:
删除旧的,添加新的一行:

这里写图片描述

为方便大家直接复制下面的:

1
<orderEntry type="jdk" jdkName="Android API 27 Platform" jdkType="Android SDK" />

修改完成后rebuild

app 上的红叉消失,显示正常,点击运行,ok

这里写图片描述

更多参考文章:

https://blog.csdn.net/CHITTY1993/article/details/78779125

https://blog.csdn.net/BruceHurrican/article/details/51755512

https://blog.csdn.net/aqi00/article/details/78858336/

本文标题:error please select android sdk

文章作者:x-sir

发布时间:2017年09月24日 - 23:47

最后更新:2018年12月08日 - 23:34

原始链接:http://www.x-sir.com/2017/09/24/error please select android sdk/

许可协议: 署名-非商业性使用-禁止演绎 4.0 国际 转载请保留原文链接及作者。

-------------本文结束感谢您的阅读-------------
坚持原创技术分享,您的支持将鼓励我继续创作!
0%